<!doctype html><!--[if IE 8]><html class="no-js lt-ie10 lt-ie9" lang="en"><![endif]--><!--[if IE 9]><html class="no-js lt-ie10" lang="en"><![endif]--><!--[if gt IE 10]><!--><html class="no-js" lang="en" ><!--<![endif]--><head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"><script type="text/javascript" src="https://www.gannett-cdn.com/uxstatic/marconews/uscp-web-static-4525.70.0/js/partner/show_ads.js"></script><title>‘Watts for Dinner’ the Takeout Edition: Treat yourself to Marco Prime</title><meta content="text/html; charset=UTF-8" name="Content-Type" /><script type="text/javascript">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</script><script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","queueTime":0,"licenseKey":"b7ac0e2ada","agent":"","transactionName":"NARUbRdVVhdSBk0MWQ1OcEwLV0wNXAsWFkIME19cFhpODVYSSl9FFw5EQA==","applicationID":"53061890","errorBeacon":"bam.nr-data.net","applicationTime":1317}</script><meta name="google" content="notranslate"><meta name="description" content="Our next dining destination is Marco Prime Steak &amp; Seafood in Marco Walk Plaza."><link rel="canonical" href="https://www.marconews.com/story/entertainment/2020/07/31/watts-dinner-takeout-edition-treat-yourself-marco-prime/5528660002/"><meta property="fb:app_id" content="540749472610264"/><meta property="fb:pages" content="6271782579,6566864515,6581478870,7197664863,7850621533,8031989578,9812439851,10482066215,11277320498,13642915529,13652355666,14073085963,16511263815,17540977705,18884137648,19125738813,23332504801,25003338948,31185662683,36808884697,37412800032,41044579289,42128399297,43612894510,46050757230,47020221001,47692649063,48490808881,48958576760,48976713989,49060990988,49607602899,49680588265,49896855793,50095226239,50978409031,52929678682,54660221594,55529405081,56434454301,56732457944,62464848082,62811590881,63475094632,63475094632,63582312713,65299040658,66049156099,66281684861,68903794473,69357466992,70423731350,70657021294,71807382333,72088679443,72139486384,73736978810,74475819815,76240820015,76276576343,77475586904,79333461561,79437403137,80117331717,80335432797,81086717085,81320873283,81668556783,81917682064,82415033847,83300095936,83563566820,87171906471,87448932499,87448932499,88584644204,90329609573,94480694479,94700656192,95712466848,95926318753,97657252278,99020906334,100825602361,101112717264,103261740968,103678546758,104331357951,104935809704,105714200321,105814368912,105878288262,106644919984,107327575587,108555442934,109146355881,109686244216,109793107867,110252103235,110404119877,110527555449,115611960606,115967868757,117907407522,118427210363,121866005065,122786733297,124755637015,125551044242,126226324691,129236178055,132159529312,132779306963,133049345480,134076752154,134394490084,136737914809,138770030135,141962110815,146089950343,148668982786,152774630192,153308622465,158094820767,164935760159,168684165430,173007618420,182922701188,188894693348,189867939238,190632318566,201996980631,227627281180,231239152914,242752084180,250325640686,264717798098,274620738925,275678631915,312966181232,314817944972,319611510288,323213251787,329923389135,338437548341,347221378913,362300531934,363363051861,371547464003,385926141498,427414745045,488720200095,100855786673970,105233922869839,105347532857165,105550656158763,106451856091222,106819879363130,107117249323169,108029922557289,108981615791456,109280192597421,109280192597421,109652569058713,110311752340743,110471702456365,110743725611909,110936258937026,111203872270080,112875149052352,113056925415668,113544088682099,113819202011100,115535341805950,115612465136194,117941352212869,119027288135308,119794264705307,119941731380546,120356424669462,121160355264720,121227371225765,121242251236815,121422567927897,124075397608772,124307640925620,124528254305153,127729820590459,128075747844406,129752560371732,130211193676772,130407246974813,130934216964240,136941796341905,137098406340114,137341919636249,137698179626815,137935586280481,138064052876960,138170199553897,140615052641118,140616965982144,141822679203700,142195472502819,143851392316295,145525478832716,146112055409819,146137498764266,146315142126130,146798045922062,147760805252234,148251148521543,149641051719383,152527031492851,152785861474173,153525871324757,154425934607982,154443518023678,155874144456588,156345381090801,157305941529632,157456661011568,158095147555989,159385590790009,160735830621443,161639923860040,165912253479205,167334979948476,167487199962004,169254356561132,169571899725267,169908223021026,176115302489104,176983469019018,177037772444433,177938742707529,180004588791896,183850168300771,183882195384562,184094471609920,184741935370451,185457134911754,187466604613310,187899791275353,190953458083653,192069610842446,196267627213508,197490563626275,205576782811630,207319989616043,209524799494208,212808112063652,220757414638542,222348701505747,224163964346315,225067797622802,225571757789261,225618707473378,231988790171331,235484153604672,236655713446291,236665340121443,241091022598958,243031846042424,251228454889939,261119230567728,263714980315631,279914708715884,281030418652036,281331052320274,285377081517877,288382484929799,288570077828603,295018040526596,297522096960113,305068052985746,307826419595702,310942265948388,315461641910509,315942225236045,315942225236045,320453738073595,321223331243188,327249521057460,330565860307724,332382433821098,334297859927211,339575256116022,351359635259904,353404615129492,368424599844024,373087836097009,399493863726488,401783903349050,405292372992577,410195352524708,412113499123835,420941268096348,421255071314156,422375144525783,426754640812333,438452439879553,458808827485318,469694573429026,471891632935599,477690595750196,480464022311783,487732368292520,510151039081225,535045576657973,535551216797440,556150611109468,562348203875693,566432520196581,569900189687627,581529871999163,592673674105043,593739520831583,611437275717153,637561026326153,642020402627050,677476185677499,686958778091339,704313986314492,717947288315597,756473301219510,757336147711096,813218208713830,850378298431411,872296879526971,877111212410602,911836215623184,917342785050040,927427260614748,945986872102221,1561238324154800,1822461518079800,1889753241275160,1003311406396687,1007667299356254,1095671673874517,1111939365618797,1170250869768985,1199725526840512,1203830176364044,1224613924286312,1244424538911767,1260369167415906,1282648301845288,1413320388972813,1422299337837954,1425793144356745,1432665186743737,1443524575938047,1473996709497771,1504884589584087,1525148737812812,1526198127405784,1583851541911383,1588113081458198,1596218533974035,1602646926431957,1603698749645413,1621466394844549,1627621717510471,1667234726635829,1725861847686522,1747180218844657,1759005871036426,1774393409526131,1797367867256626,1847787168808886,1878073225844519,1946209538938897,1972936962947967,2047091012096533" ><meta property="og:site_name" content="Marco News" /><meta name="ROBOTS" content="NOODP, NOYDIR" /><meta property="og:image" content="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/81669307-8eb4-4f03-aefb-652370d0029d-MP_1.jpg?crop=3199,1800,x0,y240&width=3200&height=1680&fit=bounds"/><meta property="og:image:width" content="3200"/><meta property="og:image:height" content="1680"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/81669307-8eb4-4f03-aefb-652370d0029d-MP_1.jpg?crop=3199,1800,x0,y240&width=1600&height=800&fit=bounds"/><meta name="twitter:site" content="@marconews" /><meta name="twitter:creator" content="@marconews" /><meta name="twitter:title" content="‘Watts for Dinner’ the Takeout Edition: Treat yourself to Marco Prime" /><meta name="twitter:description" content="Our next dining destination is Marco Prime Steak &amp; Seafood in Marco Walk Plaza." /><meta property="og:title" content="‘Watts for Dinner’ the Takeout Edition: Treat yourself to Marco Prime"/><meta property="og:description" class="speakable-description" content="Our next dining destination is Marco Prime Steak &amp; Seafood in Marco Walk Plaza."/><meta property="og:url" content="https://www.marconews.com/story/entertainment/2020/07/31/watts-dinner-takeout-edition-treat-yourself-marco-prime/5528660002/"><meta property="og:type" content="article"/><meta property="article:opinion" content="false"><meta property="article:content_tier" content="free"><script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "NewsArticle",
        "headline": "‘Watts for Dinner’ the Takeout Edition: Treat yourself to Marco Prime",
        "description": "Our next dining destination is Marco Prime Steak &amp; Seafood in Marco Walk Plaza.",
        "url": "https://www.marconews.com/story/entertainment/2020/07/31/watts-dinner-takeout-edition-treat-yourself-marco-prime/5528660002/",
        "isBasedOn": "https://www.marconews.com/story/entertainment/2020/07/31/watts-dinner-takeout-edition-treat-yourself-marco-prime/5528660002/",
        "mainEntityOfPage": {
            "@type": "WebPage",
            "@id": "https://www.marconews.com/story/entertainment/2020/07/31/watts-dinner-takeout-edition-treat-yourself-marco-prime/5528660002/"
        },
        "thumbnailUrl": "https://www.gannett-cdn.com/presto/2020/07/28/PMIF/81669307-8eb4-4f03-aefb-652370d0029d-MP_1.jpg?crop=2400,2400,x400,y0&width=150&height=150&fit=bounds",
        "image": {
            "@type": "ImageObject",
            "url": "https://www.gannett-cdn.com/presto/2020/07/28/PMIF/81669307-8eb4-4f03-aefb-652370d0029d-MP_1.jpg?crop=3199,1800,x0,y240&width=1600&height=800&fit=bounds",
            "height": 800,
            "width": 1600
        },
        "dateCreated": "2020-07-31T09:07:28.451Z",
        "dateModified": "2020-07-31T12:29:25.484Z",
        "datePublished": "2020-07-31T09:07:28.451Z",
        "articleSection": "entertainment",
        "publisher": {
            "@type": "Organization",
            "name": "Marco Eagle",
            "logo": {
                "@type": "ImageObject",
                "url": "https://www.gannett-cdn.com/sites/marconews/images/site-nav-logo@2x.png",
                "height": 80,
                "width": 297
            }
        },
        "author": ["Will Watts"],
        "keywords": [
            "ssts:entertainment",
            "type:story",
            "tag:Dining"
        ],
        "metadata": "{ \"id\": \"5528660002\",\"siteCode\": \"PMIF\",\"contentSourceCode\": \"PMIF\",\"ssts\":\"entertainment\",\"type\":\"story\"}"
    }
    </script><meta name="viewport" content="width=1070" /><link rel="shortcut icon" href="https://www.gannett-cdn.com/sites/marconews/images/favicon.png"><link rel="preload" href="https://www.gannett-cdn.com/gannett-web/global/fonts/unify/UnifySans_W_Rg.woff2" as="font" type="font/woff2" crossorigin="anonymous"><link rel="preload" href="https://www.gannett-cdn.com/gannett-web/global/fonts/unify/UnifySans_W_Bd.woff2" as="font" type="font/woff2" crossorigin="anonymous"><link rel="preload" href="https://www.gannett-cdn.com/gannett-web/global/fonts/unify/UnifySans_W_SBd.woff2" as="font" type="font/woff2" crossorigin="anonymous"><link rel="preload" href="https://www.gannett-cdn.com/gannett-web/global/fonts/gannettIcons/gannett-icons.woff" as="font" type="font/woff" crossorigin="anonymous"><!--[if gt IE 9]><!--><link data-identifier="main" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/marconews/uscp-web-static-4525.70.0/css/bundles/main_modern.min.css"><!--<![endif]--><!--[if IE 9]><link data-identifier="main" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/marconews/uscp-web-static-4525.70.0/css/bundles/common.min.css"><link data-identifier="main" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/marconews/uscp-web-static-4525.70.0/css/bundles/main.min.css"><link data-identifier="main" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/marconews/uscp-web-static-4525.70.0/css/bundles/dynamic.min.css"><![endif]--><!--[if IE 8]><link data-identifier="main" rel="stylesheet" href="/uxstatic/marconews/uscp-web-static-4525.70.0/css/bundles/common.min.css"><link data-identifier="main" rel="stylesheet" href="/uxstatic/marconews/uscp-web-static-4525.70.0/css/bundles/main.min.css"><link data-identifier="main" rel="stylesheet" href="/uxstatic/marconews/uscp-web-static-4525.70.0/css/bundles/dynamic.min.css"><![endif]--><link rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/marconews/uscp-web-static-4525.70.0/css/print.css" media="print"><!--[if gt IE 8]><!--><style>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</style><!--<![endif]--><!--[if lt IE 9]><link rel="stylesheet" href="/services/css/configs.css"><![endif]--><style></style><!--[if lt IE 9]><script src="https://www.gannett-cdn.com/uxstatic/marconews/uscp-web-static-4525.70.0/js/libs/html5shiv-printshiv.js"></script><script src="https://www.gannett-cdn.com/uxstatic/marconews/uscp-web-static-4525.70.0/js/libs/respond/respond.min.js"></script><![endif]--><!-- OneTrust Cookies Consent Notice start --><script src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" type="text/javascript" charset="UTF-8" data-domain-script="cb33c332-38ed-427f-9480-43d5a4ee33ef"></script><script type="text/javascript">function OptanonWrapper() { }</script><script src="https://cdn.cookielaw.org/opt-out/otCCPAiab.js" type="text/javascript" charset="UTF-8" ccpa-opt-out-ids="4,5" ccpa-opt-out-geo="us" ccpa-opt-out-lspa="true"></script><!-- OneTrust Cookies Consent Notice end --><script type="text/javascript">
        (function(){
            window.privacyConfig = {
                strictlyNecessary: true,
                performance: true,
                functional: true,
                targeting: true,
                socialMedia: true,
                isCcpaSubject: false
            };
            var consentCookieName = 'OptanonConsent';
            if (document.cookie.indexOf(consentCookieName) !== -1) {
                var catIds = {
                    1: 'strictlyNecessary',
                    2: 'performance',
                    3: 'functional',
                    4: 'targeting',
                    5: 'socialMedia'
                };
                function getCookie(name) {
                    var value = "; " + document.cookie;
                    var parts = value.split("; " + name + "=");
                    if (parts.length === 2) return parts.pop().split(";").shift();
                }
                var ocCookie = getCookie(consentCookieName);
                if (ocCookie) {
                    ocCookie = decodeURIComponent(ocCookie);
                    var cookieParamGroups = ocCookie.split('&');
                    var cookieParams = {};
                    for (i=0; i<cookieParamGroups.length; i++) {
                        var splitGroup = cookieParamGroups[i].split('=');
                        if (splitGroup[1]) {
                            cookieParams[splitGroup[0]] = splitGroup[1];
                        }
                    }
                    if (cookieParams.groups) {
                        var groups = cookieParams.groups.split(',');
                        for (var i=0; i<groups.length; i++) {
                            var cat = groups[i].split(':');
                            var catId = parseInt(cat[0]);
                            if (catId) {
                                var catName = catIds[catId];
                                if (catName) {
                                    window.privacyConfig[catName] = !!parseInt(cat[1]);
                                }
                            }
                        }
                    }
                    window.privacyConfig.isCcpaSubject = true;
                }
            }
        })();
    </script><script type="text/javascript">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</script></head><body class=" site-theme-dark-blue body-dr-styling " ><header data-fixed="false" data-open="true" data-default-fixed="false" data-default-open="true" class=" site-header header-light "><div class="site-header-inner-wrap "><div class="partner-nanobar"><div class="partner-placement partner-nanobar-ad" data-ad-placement="consumer_sales-nano_bar" data-ad-sizes="[[1025,80], 'fluid']"></div></div><div class="site-masthead"><a class="site-masthead-logo-link logo-link" data-ht="Headermarconews Headerlogoexpanded" href="/" ><img class="site-masthead-logo-img" src="https://www.gannett-cdn.com/sites/marconews/images/site-masthead-logo-dark@2x.png" height="80" alt="Marco News"></a><div class="site-masthead-search-wrap"><form class="site-masthead-search-form ui-ajax-form" action="/search/" method="get" data-mapping="<%= q %>/"></form></div></div><nav class="site-nav"><ul class="site-nav-list site-nav-list-marconews "><li class="site-nav-item site-nav-end-item site-nav-logo-item"><a class="site-nav-link site-nav-logo-link" data-ht="Headerlogocollapsed" href="/"  ><img class="site-nav-logo-img " src="https://www.gannett-cdn.com/sites/marconews/images/site-nav-logo-dark@2x.png" height="40" alt="Marco News"></a></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-end-item site-nav-first-primary-item site-nav-text-item site-nav-home-item site-nav-module site-nav-home-module" id="module-position-S5x8jyjXAwA"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-marconews site-nav-link-theme-dark-blue site-nav-end-link site-nav-first-primary-link site-nav-text-link site-nav-home-link" href="/" data-ht="Headerhome"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-end-span site-nav-first-primary-span site-nav-text-span site-nav-home-span">Home</span><span class="site-nav-theme-border home-theme-bg dark-blue-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-text-item site-nav-news-item site-nav-module site-nav-news-module" id="module-position-S5x8jyi-J8Q"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-marconews site-nav-link-theme-dark-blue site-nav-text-link site-nav-news-link" href="/news/" data-ht="Headernews"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-text-span site-nav-news-span">News</span><span class="site-nav-theme-border news-theme-bg dark-blue-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-text-item site-nav-sports-item site-nav-module site-nav-sports-module" id="module-position-S5x8jyjUGrM"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-marconews site-nav-link-theme-dark-blue site-nav-text-link site-nav-sports-link" href="/news/sports/" data-ht="Headersports"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-text-span site-nav-sports-span">Sports</span><span class="site-nav-theme-border sports-theme-bg dark-blue-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-text-item site-nav-life-item site-nav-module site-nav-life-module" id="module-position-S5x8jyij2Nw"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-marconews site-nav-link-theme-dark-blue site-nav-text-link site-nav-life-link" href="/things-to-do/life/" data-ht="Headerlife"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-text-span site-nav-life-span">Life</span><span class="site-nav-theme-border life-theme-bg dark-blue-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-text-item site-nav-opinion-item site-nav-module site-nav-opinion-module" id="module-position-S5x8jyiAD8c"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-marconews site-nav-link-theme-dark-blue site-nav-text-link site-nav-opinion-link" href="/news/opinion/" data-ht="Headeropinion"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-text-span site-nav-opinion-span">Opinion</span><span class="site-nav-theme-border opinion-theme-bg dark-blue-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-text-item site-nav-entertainment-item site-nav-module site-nav-entertainment-module" id="module-position-S5x8jyilVxs"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-marconews site-nav-link-theme-dark-blue site-nav-text-link site-nav-entertainment-link" href="/entertainment/" data-ht="Headerentertainment"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-text-span site-nav-entertainment-span">Entertainment</span><span class="site-nav-theme-border entertainment-theme-bg dark-blue-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-text-item site-nav-travel-item site-nav-module site-nav-travel-module" id="module-position-S5x8jyjOTjA"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-marconews site-nav-link-theme-dark-blue site-nav-text-link site-nav-travel-link" href="/travel/" data-ht="Headertravel"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-text-span site-nav-travel-span">Travel</span><span class="site-nav-theme-border travel-theme-bg dark-blue-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-text-item site-nav-obituaries-item site-nav-module site-nav-obituaries-module" id="module-position-S5x8jyjYYTM"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-marconews site-nav-link-theme-dark-blue site-nav-external-text-link site-nav-text-link site-nav-obituaries-link" href="http://www.legacy.com/obituaries/naplesnews/" data-ht="Headerobituaries" target="_blank"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-text-span site-nav-obituaries-span">Obituaries</span><span class="site-nav-theme-border obituaries-theme-bg dark-blue-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-text-item site-nav-naples-news-item site-nav-module site-nav-naples-news-module" id="module-position-S5x8jyiqenE"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-marconews site-nav-link-theme-dark-blue site-nav-external-text-link site-nav-text-link site-nav-naples-news-link" href="http://www.naplesnews.com" data-ht="Headernaples-news" target="_blank"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-text-span site-nav-naples-news-span">Naples Daily News</span><span class="site-nav-theme-border naples-news-theme-bg dark-blue-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-text-item site-nav-usa-today-item site-nav-module site-nav-usa-today-module" id="module-position-S5x8jyituzA"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-marconews site-nav-link-theme-dark-blue site-nav-external-text-link site-nav-text-link site-nav-usa-today-link" href="https://www.usatoday.com" data-ht="Headerusa-today" target="_blank"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-text-span site-nav-usa-today-span">USA TODAY</span><span class="site-nav-theme-border usa-today-theme-bg dark-blue-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-end-item site-nav-last-primary-item site-nav-text-item site-nav-weather-item site-nav-module site-nav-weather-module" id="module-position-S5x8jyj-2tE"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-marconews site-nav-link-theme-dark-blue site-nav-end-link site-nav-last-primary-link site-nav-text-link site-nav-weather-link" href="/weather/" data-ht="Headerweather"><div class="site-nav-span-wrap site-nav-text-span-wrap"><span class="site-nav-span site-nav-text-span site-nav-alt-span site-nav-weather-span wbtn-wrap-wicon" data-weather="temperature" data-weather-suffix="&deg;"></span><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-end-span site-nav-last-primary-span site-nav-text-span site-nav-weather-span">Weather</span></div><span class="site-nav-theme-border weather-theme-bg dark-blue-theme-bg" ></span></a><div class="weather-nav-dropdown header-light"><div class="weather-nav-dropdown-panel-wrap"><div class="weather-nav-conditions-panel"><p class="weather-nav-location-name"></p><div class="weather-nav-dropdown-time" data-weather="observationTime"></div><div class="weather-nav-dropdown-wicon">Icon</div><div class="weather-nav-dropdown-temp" data-weather="temperature" data-weather-suffix="&deg;"></div><ul class="weather-nav-conditions-wrap"><li class="weather-nav-condition-humidity"><span class="weather-nav-condition-title">Humidity</span><span class="weather-nav-condition-value" data-weather="humidity" data-weather-suffix=" "></span></li><li class="weather-nav-condition-precip"><span class="weather-nav-condition-title">Precip.</span><span class="weather-nav-condition-value" data-weather="precip" data-weather-suffix=" in"></span></li><li class="weather-nav-condition-wind"><span class="weather-nav-condition-title">Winds</span><span class="weather-nav-condition-value" data-weather="windSpeed" data-weather-suffix=" mph"></span></li></ul><div class="weather-nav-dropdown-settings-open-btn">Open settings</div></div><div class="weather-nav-settings-panel"><p class="weather-nav-settings-header">Settings</p><form class="weather-nav-location-form" method="get"><label class="weather-nav-location-input-label">Enter City Name</label><div class="ui-form-field-container weather-nav-location-input-wrap"><input class="ui-text-input weather-nav-location-input" type="text" data-clearable="true" data-autocomplete-url="/weather/cities/v2/search.json?q=<%=encodeURIComponent(query)%>" value="" /><div class="weather-nav-location-error"></div></div><p class="ui-btn header-nav-dropdown-dark-btn weather-nav-location-cancel-btn">Cancel</p><p class="ui-btn header-nav-dropdown-light-btn weather-nav-location-set-btn">Set</p></form><div class="weather-nav-dropdown-settings-close-btn">Close settings</div></div></div><a href="/weather/" class="weather-nav-full-forecast-btn" data-track-label="hoveroverweather|fullforecast">Full Forecast</a></div></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-more-item site-nav-text-item site-nav-module site-nav-text-module" id="module-position-"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-marconews site-nav-link-theme-dark-blue site-nav-more-link site-nav-text-link" href="" data-ht="Headertext"><div class="site-nav-span-wrap site-nav-more-span-wrap"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-more-span site-nav-text-span">More<span class="site-nav-more-arrow"></span></span></div></a><div class="site-nav-dropdown site-nav-more-dropdown site-nav-more-dropdown-1col"><div class="site-nav-dropdown-inner-wrap site-nav-more-dropdown-inner-wrap"><ul class="site-nav-more-dropdown-list site-nav-more-dropdown-list-1col"><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/" data-ht="Headermorehome">Home</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/news/" data-ht="Headermorenews">News</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/news/sports/" data-ht="Headermoresports">Sports</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/things-to-do/life/" data-ht="Headermorelife">Life</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/news/opinion/" data-ht="Headermoreopinion">Opinion</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/entertainment/" data-ht="Headermoreentertainment">Entertainment</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/travel/" data-ht="Headermoretravel">Travel</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="http://www.legacy.com/obituaries/naplesnews/" data-ht="Headermoreobituaries">Obituaries</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="http://www.naplesnews.com" data-ht="Headermorenaples-news">Naples Daily News</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="https://www.usatoday.com" data-ht="Headermoreusa-today">USA TODAY</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/weather/" data-ht="Headermoreweather">Weather</a></li></ul></div></div></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-spacer-item site-nav-spacer-item site-nav-module site-nav-spacer-module" id="module-position-"><span class="site-nav-inner-wrap"></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-secondary-item site-nav-end-item site-nav-first-secondary-item site-nav-end-item site-nav-last-secondary-item site-nav-icon-item site-nav-search-item site-nav-module site-nav-search-module" id="module-position-S5x8jylDxnY"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-marconews site-nav-link-theme-dark-blue site-nav-end-link site-nav-first-secondary-link site-nav-end-link site-nav-last-secondary-link site-nav-icon-link site-nav-search-link" href="" data-ht="Headersearch"><div class="site-nav-span-wrap site-nav-icon-span-wrap"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-end-span site-nav-first-secondary-span site-nav-end-span site-nav-last-secondary-span site-nav-icon-span site-nav-search-span">Search</span></div><span class="site-nav-theme-border search-theme-bg dark-blue-theme-bg" ></span></a><div class="site-nav-dropdown site-nav-search-dropdown"><div class="site-nav-dropdown-inner-wrap site-nav-search-dropdown-inner-wrap"><form class="site-masthead-search-form ui-ajax-form" action="/search/" method="get" data-mapping="<%= q %>/"><input class="site-masthead-search-form-input" data-clearable="true" type="text" name="q" autocomplete="off" placeholder="Search"><button class="site-masthead-search-form-submit" type="submit" value=""></button></form></div></div></span></li></ul></nav><div class="bnm-container"></div></div><script type="json/headermodules" class="headermodules headermodules-primary">{ "js_modules": [{"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "S5x8jyjXAwA", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "S5x8jyi-J8Q", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "S5x8jyjUGrM", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "S5x8jyij2Nw", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "S5x8jyiAD8c", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "S5x8jyilVxs", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "S5x8jyjOTjA", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "S5x8jyjYYTM", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "S5x8jyiqenE", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "S5x8jyituzA", "options": null, "oembedprovider": null}, {"name": "site-nav-weather-module", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "S5x8jyj-2tE", "options": null, "oembedprovider": null}] }</script><script type="json/headermodules" class="headermodules headermodules-secondary">{ "js_modules": [{"name": "site-nav-search-module", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "S5x8jylDxnY", "options": null, "oembedprovider": null}] }</script></header><div id="overlay"><div class="partner-placement partner-gravity-ad partner-gravity-ad-"><div class="gravity-viewable" id="gravity-viewable"></div><svg xmlns="http://www.w3.org/2000/svg" class="partner-scroll"><defs><filter id="dropshadow" height="130%"><feGaussianBlur in="SourceAlpha" stdDeviation="2"/><feOffset dx="1" dy="1" result="offsetblur"/><feComponentTransfer><feFuncA type="linear" slope="0.4"/></feComponentTransfer><feMerge><feMergeNode/><feMergeNode in="SourceGraphic"/></feMerge></filter></defs><g transform="translate(0 1)" fill="none" fill-rule="evenodd" filter="url(#dropshadow)"><path d="M6.327 17.195c.92 0 1.76-.122 2.52-.367s1.356-.588 1.786-1.028v-4.665H6.238v2.025h1.814v1.5c-.44.15-.884.225-1.334.225-.96 0-1.693-.248-2.198-.742-.505-.495-.757-1.248-.757-2.258 0-.9.222-1.62.667-2.16.445-.54 1.067-.81 1.868-.81.44 0 .842.093 1.207.278.365.184.653.447.862.787l2.235-1.305c-1.01-1.38-2.434-2.07-4.275-2.07-1.08 0-2.024.222-2.834.667a4.778 4.778 0 00-1.89 1.853c-.45.79-.675 1.71-.675 2.76 0 1.05.222 1.975.667 2.775.445.8 1.07 1.422 1.875 1.867.805.445 1.757.668 2.857.668zM19.797 17v-2.235h-4.545v-1.77h3.825V10.76h-3.825V9.035h4.306V6.8h-7.035V17h7.274zm6.796 0V9.05h3.03V6.8h-8.85v2.25h3.03V17h2.79zm13.14 0V9.05h3.03V6.8h-8.85v2.25h3.03V17h2.79zm7.29 0v-3.99h3.464V17h2.79V6.8h-2.79v3.93h-3.465V6.8h-2.79V17h2.79zm15.78 0v-2.235h-4.545v-1.77h3.825V10.76h-3.825V9.035h4.304V6.8h-7.034V17h7.275zm7.92 0v-5.88L74.727 17h2.55V6.8h-2.58v5.985L70.708 6.8h-2.55V17h2.564zm16.08 0v-2.235h-4.546v-1.77h3.825V10.76h-3.825V9.035h4.305V6.8h-7.034V17h7.274zm6.404 0l1.65-6.63 1.65 6.63h2.956l2.535-10.2h-2.656l-1.59 6.915L96.058 6.8h-2.386l-1.71 6.96-1.544-6.96h-2.7L90.252 17h2.956zm13.8.195c.81 0 1.52-.135 2.13-.405.61-.27 1.083-.648 1.418-1.132.335-.486.502-1.053.502-1.703 0-.69-.227-1.295-.682-1.815-.455-.52-1.233-.93-2.332-1.23l-.766-.21c-.55-.15-.937-.313-1.162-.487-.225-.175-.337-.383-.337-.623 0-.26.107-.457.322-.592.215-.135.523-.203.922-.203.48 0 .963.115 1.448.345.485.23.907.5 1.267.81l1.395-1.755a6.398 6.398 0 00-1.89-1.163 5.944 5.944 0 00-2.235-.427c-.79 0-1.485.132-2.085.397-.6.266-1.07.643-1.41 1.133-.34.49-.51 1.06-.51 1.71 0 .76.24 1.387.72 1.882.48.495 1.18.863 2.1 1.103l.63.165c.68.18 1.156.353 1.425.518.27.165.406.382.406.652a.69.69 0 01-.346.63c-.23.14-.544.21-.944.21-.6 0-1.15-.103-1.65-.308-.5-.204-.95-.487-1.35-.847l-1.35 1.695c.56.53 1.22.938 1.98 1.222.76.285 1.554.428 2.384.428z" fill="currentcolor" fill-rule="nonzero"/><circle stroke="currentcolor" stroke-width="2" cx="132" cy="12" r="12"/><path d="M132.573 14.863v-7.29a.573.573 0 00-1.146 0v7.29h0l-2.213-2.182a.578.578 0 00-.809-.002.553.553 0 00-.001.79l3.349 3.288a.353.353 0 00.494 0l3.35-3.287a.553.553 0 00-.002-.791.578.578 0 00-.809.002l-2.213 2.182h0z" stroke="currentcolor" fill="currentcolor" fill-rule="nonzero"/></g></svg></div><div class="transition-wrap" ><div class="partner-placement partner-brandlock" data-ad-placement="sponsor_logo" data-ad-sizes="[[300, 50]]"></div><div class="partner-placement partner-overlay-top-ad partner-has-min-height" style="min-height:250px" data-ad-placement="high_impact" data-ad-sizes="[[970,250],[728,90]]"></div><article class="asset story clearfix" ><div class="close-wrap"><a href="#" class="close close-overlay" data-ht="modalclose"></a></div><div class="utility-bar-wrap"><div class="utility-bar"><div class="util-bar-primary-modules"><div class="util-bar-module util-bar-module-share"><div
                    class="util-bar-btn util-bar-btn-facebook util-bar-btn-share"
                    data-module-name="utility-bar-module-share"
                    data-module-section="share"
                    data-uotrack="UtilityBarFacebookBtn"></div><a
                    class="util-bar-btn util-bar-btn-twitter"
                    data-module-name="share-twitter"
                    data-popup-width="550"
                    data-popup-height="450"
                    data-uotrack="UtilityBarTwitterLink"
                    href="https://twitter.com/intent/tweet?url=https%3A//www.marconews.com/story/entertainment/2020/07/31/watts-dinner-takeout-edition-treat-yourself-marco-prime/5528660002/&amp;text=%E2%80%98Watts%20for%20Dinner%E2%80%99%20the%20Takeout%20Edition%3A%C2%A0Treat%20yourself%20to%20Marco%20Prime&amp;via=marconews"
                    target="_blank" data-popup
                    rel="nofollow"></a><a class="util-bar-btn util-bar-btn-linkedin"
                    data-share-method="linkedin"
                    data-popup-width="600"
                    data-popup-height="455"
                    data-uotrack="UtilityBarFlyoutLinkedInLink"
                    href="http://www.linkedin.com/shareArticle?url=https%3A//www.marconews.com/story/entertainment/2020/07/31/watts-dinner-takeout-edition-treat-yourself-marco-prime/5528660002/&amp;mini=true"
                    target="_blank" data-popup
                    rel="nofollow"></a><div
                    class="util-bar-btn util-bar-btn-email js-share-email-btn"
                    data-module-name="utility-bar-module-share"
                    data-module-section="email"
                    data-uotrack="UtilityBarEmailBtn"></div><div class="util-bar-flyout util-bar-flyout-share"><div class="util-bar-flyout-pane util-bar-flyout-pane-share scrollable-content"><div class="util-bar-flyout-heading util-bar-flyout-heading-share"><h6 class="util-bar-flyout-title util-bar-flyout-title-share">Share This Story!</h6><p class="util-bar-flyout-subtitle util-bar-flyout-subtitle-share">Let friends in your social network know what you are reading about</p></div><div class="util-bar-flyout-nav util-bar-flyout-nav-share"><span class="util-bar-flyout-nav-btn-wrap"><span
                                    class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-facebook active"
                                    data-share-method="facebook"
                                    data-uotrack="UtilityBarFlyoutFacebookBtn"
                                >Facebook</span></span><span class="util-bar-flyout-nav-btn-wrap"><span
                                        class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-email"
                                        data-share-method="email"
                                        data-uotrack="UtilityBarFlyoutEmailBtn"
                                    >Email</span></span><span class="util-bar-flyout-nav-btn-wrap"><a
                                    class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-twitter"
                                    data-share-method="twitter"
                                    data-popup-width="550"
                                    data-popup-height="450"
                                    data-uotrack="UtilityBarFlyoutTwitterLink"
                                    href="https://twitter.com/intent/tweet?url=https%3A//www.marconews.com/story/entertainment/2020/07/31/watts-dinner-takeout-edition-treat-yourself-marco-prime/5528660002/&amp;text=%E2%80%98Watts%20for%20Dinner%E2%80%99%20the%20Takeout%20Edition%3A%C2%A0Treat%20yourself%20to%20Marco%20Prime&amp;via=marconews"
                                    target="_blank" data-popup
                                >Twitter</a></span><span class="util-bar-flyout-nav-btn-wrap"><a
                                    class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-googleplus"
                                    data-share-method="googleplus"
                                    data-popup-width="500"
                                    data-popup-height="500"
                                    data-uotrack="UtilityBarFlyoutGooglePlusLink"
                                    href="//plus.google.com/share?url=https%3A//www.marconews.com/story/entertainment/2020/07/31/watts-dinner-takeout-edition-treat-yourself-marco-prime/5528660002/"
                                    target="_blank" data-popup
                                >Google+</a></span><span class="util-bar-flyout-nav-btn-wrap"><a
                                    class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-linkedin"
                                    data-share-method="linkedin"
                                    data-popup-width="600"
                                    data-popup-height="455"
                                    data-uotrack="UtilityBarFlyoutLinkedInLink"
                                    href="http://www.linkedin.com/shareArticle?url=https%3A//www.marconews.com/story/entertainment/2020/07/31/watts-dinner-takeout-edition-treat-yourself-marco-prime/5528660002/&amp;mini=true"
                                    target="_blank" data-popup
                                >LinkedIn</a></span><span class="util-bar-flyout-nav-btn-wrap"><a
                                        href="//www.pinterest.com/pin/create/button/?url=https%3A//www.marconews.com/story/entertainment/2020/07/31/watts-dinner-takeout-edition-treat-yourself-marco-prime/5528660002/&media=https://www.gannett-cdn.com/presto/2020/07/28/PMIF/81669307-8eb4-4f03-aefb-652370d0029d-MP_1.jpg?crop=3199,1800,x0,y240&width=3200&height=1680&fit=bounds&description=Our next dining destination is Marco Prime Steak & Seafood in Marco Walk Plaza."
                                        data-pin-do="buttonPin"
                                        data-pin-config="above"
                                        class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-pinterest"
                                        data-share-method="pinterest"
                                        data-popup-width="600"
                                        data-popup-height="455"
                                        data-uotrack="UtilityBarFlyoutPinterestLink"
                                        target="_blank" data-popup
                                        >Pinterest</a></span></div><div class="util-bar-share-summary"><img class="util-bar-share-summary-image" height="60" width="60" data-src="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/81669307-8eb4-4f03-aefb-652370d0029d-MP_1.jpg?crop=2400,2400,x400,y0&width=60&height=60&fit=bounds" alt="" /><h4 class="util-bar-share-summary-title">‘Watts for Dinner’ the Takeout Edition: Treat yourself to Marco Prime</h4><p class="util-bar-share-summary-description">Our next dining destination is Marco Prime Steak & Seafood in Marco Walk Plaza.</p></div><div class="util-bar-flyout-section util-bar-flyout-section-facebook"><form method="post" class="util-bar-share-form-facebook"><div
                                    class="util-bar-share-message-facebook"
                                    data-link="https://www.marconews.com/story/entertainment/2020/07/31/watts-dinner-takeout-edition-treat-yourself-marco-prime/5528660002/"
                                    data-image="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/81669307-8eb4-4f03-aefb-652370d0029d-MP_1.jpg?crop=3199,1800,x0,y240&width=3200&height=1680&fit=bounds"
                                    data-title="‘Watts for Dinner’ the Takeout Edition: Treat yourself to Marco Prime"></div><div class="util-bar-share-submit-wrap-facebook"><span class="util-bar-share-form-status-facebook"><img class="util-bar-share-loading-facebook" src="https://www.gannett-cdn.com/uxstatic/marconews/uscp-web-static-4525.70.0/images/indicators/facebook-loading.gif" alt="Loading&hellip;"><span class="util-bar-share-status-text-facebook"></span></span><span class="util-bar-share-submit-btn-facebook">Post to Facebook</span></div></form></div><div class="share-email-container js-share-email-container"><div class="share-email-form-container js-share-email-form-container"><form action="/services/mail/v4/send/" method="post" class="share-email-form js-share-email-form"><input type="hidden" name="email_type" value="share_email" class="share-email-form-input "><input type="hidden" name="share_title" value="‘Watts for Dinner’ the Takeout Edition: Treat yourself to Marco Prime" class="share-email-form-input"><input type="text" name="your_name" class="email-to optional share-email-form-input ui-text-input" placeholder="Your Name"><input type="text" name="from" class="email-to required share-email-form-input ui-text-input "
                       placeholder="Your Email"><input type="text" name="to" class="email-from required share-email-form-input ui-text-input "
                       placeholder="Your Friend's Email"><textarea class="email-message share-email-form-textarea js-share-email-form-textarea ui-textarea " name="message"
                          placeholder="Message (optional)">‘Watts for Dinner’ the Takeout Edition: Treat yourself to Marco Prime &#13;&#13;Our next dining destination is Marco Prime Steak & Seafood in Marco Walk Plaza.  &#13;&#13;Check out this story on marconews.com: https://www.marconews.com/story/entertainment/2020/07/31/watts-dinner-takeout-edition-treat-yourself-marco-prime/5528660002/</textarea><script src="https://www.google.com/recaptcha/api.js" async defer></script><div id="recaptcha-share" data-key="6LcAqiIUAAAAAJfFpgRBPCU3IjPQm6roffmp1zCE"></div><div class="email-form-buttons share-email-form-buttons"><span class="ui-chunky-btn secondary icon cancel share-email-form-cancel-btn js-share-email-cancel-btn">Cancel</span><span class="ui-chunky-btn icon send share-email-form-send-btn js-share-email-send-btn">Send</span></div></form></div><div class="share-email-success-pane js-share-email-form-success-pane"><h4 class="share-email-success-pane-title">Sent!</h4><p class="share-email-success-pane-description">A link has been sent to your friend's email address.</p></div></div></div><div class="util-bar-flyout-pane util-bar-flyout-pane-success util-bar-flyout-pane-success-facebook"><h4 class="util-bar-success-title util-bar-success-title-facebook">Posted!</h4><p class="util-bar-success-description util-bar-success-description-facebook">A link has been posted to your Facebook feed. </p></div><div class="util-bar-flyout-close-ribbon"></div></div></div><div class="util-bar-module util-bar-module-comments"><div
                        class="util-bar-btn util-bar-btn-comments"
                        data-uotrack="UtilityBarCommentsBtn"
                        data-module-name="utility-bar-module-comments"></div><div class="util-bar-flyout util-bar-flyout-comments"><div class="util-bar-flyout-heading util-bar-flyout-heading-comments hidden"><h6 class="util-bar-flyout-title util-bar-flyout-title-comments">Join the Conversation</h6><p class="util-bar-flyout-subtitle util-bar-flyout-subtitle-comments">To find out more about Facebook commenting please read the <a href="http://static.marconews.com/conversation-guidelines/">Conversation Guidelines and FAQs</a></p></div><div class="util-bar-comments-wrap"><div class="util-bar-scroll-wrap util-bar-scroll-wrap-comments"><div class="facebook-comments-plugin-wrap scrollable-content hidden"><div class="fb-comments" data-href="https://www.marconews.com/story/entertainment/2020/07/31/watts-dinner-takeout-edition-treat-yourself-marco-prime/5528660002/" data-posts="20" data-width="400"></div></div><div class="coral-talk-comments-plugin-wrap scrollable-content hidden"><div class="coral-talk-header"><h2 class="coral-talk-title">Comments</h2><p class="coral-talk-message">
                                            Welcome to our new and improved comments<span class="coral-talk-subscribers-only hidden">, which are for subscribers only</span>.
                                            This is a test to see whether we can improve the experience for you.
                                            You do not need a Facebook profile to participate.
                                        </p><p class="coral-talk-message">
                                            You will need to register before adding a comment.
                                            Typed comments will be lost if you are not logged in.
                                        </p><p class="coral-talk-message">
                                            Please be polite.
                                            It's OK to disagree with someone's ideas, but personal attacks, insults, threats, hate speech, advocating violence and other violations can result in a ban.
                                            If you see comments in violation of our <a class="coral-talk-header-link" href="//static.marconews.com/conversation-guidelines/" data-track-label="exit|commentscommunityrules">community guidelines</a>, please report them.
                                        </p></div><div class="coral-talk-embed-wrap"></div><iframe class="gup-embed hidden"></iframe></div></div></div><div class="util-bar-flyout-close-ribbon"></div></div></div></div><div class="util-bar-secondary-modules"><div class="util-bar-module util-bar-module-print"><div
                        class="util-bar-btn util-bar-btn-print"
                        data-uotrack="UtilityBarPrintBtn"
                        data-module-name="utility-bar-module-print"></div></div></div></div></div><section id="module-position-S5x9hDAev_0" class="storytopbar-bucket asset-nav-bar-module story-asset-nav-bar-module"></section><section id="module-position-S5x9hDA8qso" class="storytopbar-bucket story-headline-module story-story-headline-module"><h1 class="asset-headline speakable-headline" itemprop="headline">‘Watts for Dinner’ the Takeout Edition: Treat yourself to Marco Prime</h1></section><section id="module-position-S5x9hDBehtg" class="storytopbar-bucket priority-asset-module story-priority-asset-module"></section><section id="module-position-S5x9hDBXW-w" class="storytopbar-bucket story-byline-module story-story-byline-module"><div class="asset-metabar"><span class="asset-metabar-author asset-metabar-item">Will Watts, Correspondent</span><span class="asset-metabar-time asset-metabar-item nobyline">
            Published 5:07 a.m. ET July 31, 2020 | <span class="asset-metabar-time-updated">Updated 8:29 a.m. ET July 31, 2020</span></span></div></section><section id="module-position-S5x9hDBNfsE" class="storytopbar-bucket piano-module story-piano-module"></section><section id="module-position-S5x9hDAw6aU" class="storytopbar-bucket bounce-exchange-module story-bounce-exchange-module"></section><!-- p402_premium class is utilized by Google Consumer Surveys --><div class="asset-double-wide double-wide p402_premium" role="main" itemprop="mainEntity articleBody"><div id="module-position-S5x9hHvGtPU" class="story-asset video-asset"><div class="ui-video-wrapper " itemprop="video" itemscope itemtype="http://schema.org/VideoObject" ><script src="https://www.gannett-cdn.com/gannett-web/apps/teal/dist/vendor/hls/hls.light.0.12.4.min.require.js" async></script><script src="https://imasdk.googleapis.com/js/sdkloader/ima3.js" async></script><script src="https://www.gannett-cdn.com/gannett-web/apps/teal/dist/vendor/ias/ias-3.5.1.min.js" async></script><script src="https://www.gannett-cdn.com/gannett-web/apps/teal/dist/vendor/adobe/MediaSDK.2.2.0.min.require.js" async></script><script src="https://www.gannett-cdn.com/gannett-web/apps/teal/dist/vendor/comscore/streamsense-5.1.1.160316.min.js" async></script><div class="story-video js-video-avp automatedvideoplayerhidden automatedvideoplayer ui-teal-video js-teal-player js-ui-video-init"><div class="teal-video-wrap"><video
                        playsinline
                        poster="https://www.gannett-cdn.com/presto/2020/07/30/USAT/71f454e7-c180-43d0-9bca-c940ed82fcff-20200730_197_OPRAH_FINAL.jpg?width=400" style="width: 400px; height: 225px;"></video><div class="tealplayer-ad-container"></div></div><div class="js-ptb pluto-title-bar"><div class="pluto-title-bar-vcenter pluto-title-bar-text"></div><div class="js-ptb-close pluto-title-bar-vcenter pluto-title-bar-close"><div>CLOSE<img class="pluto-title-bar-close-icon" src="https://www.gannett-cdn.com/uxstatic/marconews/uscp-web-static-4525.70.0/images/sprites/icon_close.png"></div></div></div><script type='json/data' class='ui-video-data'>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</script><script type='json/data' class='ui-video-placement-data'>{"apsEnabled": true, "hls": {"excludeRenditions": true}, "enableLogging": true, "height": 225, "analyticsEnabled": true, "enableTealPlayer": true, "scrollingplayer": false, "enableSnowPlayer": false, "disableDescription": true, "ads": true, "width": 400, "enable": true, "share": true, "unlimitedAds": {"maxFailures": 1, "enabled": true, "requiredPlays": 0}, "uwConfigParams": "&pagetype=story", "name": "automatedvideoplayer", "enableUwPlayer": false, "uwAutoplay": true, "mutedAutoplay": true, "gannett_continuous_endslate": true, "mediatemplate": false, "embed": true, "autoplay": true}</script></div><div class="ui-video-controls story-video js-video-avp automatedvideoplayerhidden" style="width: 400px;"><meta itemprop="description" content="Breonna Taylor is on the cover of September&#39;s &quot;O, The Oprah Magazine.&quot; It&#39;s the first cover in the publication&#39;s history to not feature Oprah Winfrey." /></div></div></div><div id="module-position-S5x9hHvgLFc" class="story-asset gallery-asset"><div class="card-film inactive"></div><div class="sidebar-gallery-btn active"></div><div class="companion-story-gallery js-llc" data-name="compStoryGallery"><div class="gallery-sidebar-panel has-leaderboard"><span class="gallery-sidebar-close"></span><div class="gallery-sidebar-toolbox share-pane social-pane "><span class="util-bar-flyout-nav-btn-wrap"><span
            class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-facebook gallery-util-bar-flyout-nav-btn"
            href="#"
            target="_blank"
            data-share-link="https://www.marconews.com/picture-gallery/entertainment/2020/07/31/photos-marco-prime-2020/5528722002/"
            data-share-title=""
            data-share-method="facebook"
            data-uotrack="UtilityBarFlyoutFacebookBtn"
        >Facebook</span></span><span class="util-bar-flyout-nav-btn-wrap"><a
            class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-twitter gallery-util-bar-flyout-nav-btn"
            data-share-method="twitter"
            data-popup-width="550"
            data-popup-height="450"
            data-uotrack="UtilityBarFlyoutTwitterLink"
            href="https://twitter.com/intent/tweet?url=https://www.marconews.com/picture-gallery/entertainment/2020/07/31/photos-marco-prime-2020/5528722002/&amp;text=%E2%80%98Watts%20for%20Dinner%E2%80%99%20the%20Takeout%20Edition:%C2%A0Treat%20yourself%20to%20Marco%20Prime&amp;via=marconews"
            target="_popup"
        >Twitter</a></span><span class="util-bar-flyout-nav-btn-wrap"><a
            class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-googleplus gallery-util-bar-flyout-nav-btn"
            data-share-method="googleplus"
            data-popup-width="500"
            data-popup-height="500"
            data-uotrack="UtilityBarFlyoutGooglePlusLink"
            href="//plus.google.com/share?url=https://www.marconews.com/picture-gallery/entertainment/2020/07/31/photos-marco-prime-2020/5528722002/"
            target="_popup"
        >Google+</a></span><span class="util-bar-flyout-nav-btn-wrap"><a
            class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-linkedin gallery-util-bar-flyout-nav-btn"
            data-share-method="linkedin"
            data-popup-width="1000"
            data-popup-height="455"
            data-uotrack="UtilityBarFlyoutLinkedInLink"
            href="http://www.linkedin.com/shareArticle?url=https://www.marconews.com/picture-gallery/entertainment/2020/07/31/photos-marco-prime-2020/5528722002/&mini=true"
            target="_popup"
        >LinkedIn</a></span></div><div class="title gallery-sidebar-title selected">Photos: Marco Prime, 2020</div><div class="gallery-sidebar-fullscreen"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen">&nbsp;</span>Fullscreen</a></div><div class="caption"></div><div class="gallery-sidebar-flyout-section util-bar-flyout-section util-bar-flyout-section-facebook"><form method="post" class="util-bar-share-form-facebook"><div
            class="util-bar-share-message-facebook"
            data-link="https://www.marconews.com/picture-gallery/entertainment/2020/07/31/photos-marco-prime-2020/5528722002/"
            data-title="‘Watts for Dinner’ the Takeout Edition: Treat yourself to Marco Prime"
            placeholder="Message (optional)"></div><div class="util-bar-share-submit-wrap-facebook"><span class="util-bar-share-form-status-facebook"><img class="util-bar-share-loading-facebook" src="https://www.gannett-cdn.com/uxstatic/marconews/uscp-web-static-4525.70.0/images/indicators/facebook-loading.gif"><span class="util-bar-share-status-text-facebook"></span></span><span class="util-bar-share-submit-btn-facebook">Post to Facebook</span></div></form></div><div class="util-bar-flyout-pane util-bar-flyout-pane-success util-bar-flyout-pane-success-facebook"><h4 class="util-bar-success-title util-bar-success-title-facebook">Posted!</h4><p class="util-bar-success-description util-bar-success-description-facebook">A link has been posted to your Facebook feed. </p></div><div class="companion-galleries-partner-slot"></div></div><div class="companion-galleries embedded_story hasendslate galleries"
        data-gallery-id="5528722002"
        data-title="Photos: Marco Prime, 2020"
        data-seo-title="Photos: Marco Prime, 2020"
        data-ssts="entertainment"
        data-cst="entertainment"
        data-published-date="2020-07-31T09:07:27.618Z"
        
        
         data-gal-pageurl="https://www.marconews.com/picture-gallery/entertainment/2020/07/31/photos-marco-prime-2020/5528722002/"><div class="viewport gallery-viewport"><div class="slide gallery-viewport-slide  active"  itemprop="primaryImageOfPage"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo  gallery-photo-first" data-mycapture-src="" data-mycapture-sm-src=""
                                
                                    data-src="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/81669307-8eb4-4f03-aefb-652370d0029d-MP_1.jpg?width=520&amp;height=390&amp;fit=bounds&amp;auto=webp"
                                    data-large-src="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/81669307-8eb4-4f03-aefb-652370d0029d-MP_1.jpg?width=1920&amp;height=1440&amp;fit=bounds&amp;auto=webp"
                                
                                alt="The fennel tuna from Marco Prime, Marco Island." data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="292" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption gallery-viewport-caption-no-mycapture"><span class="js-caption">The fennel tuna from Marco Prime, Marco Island.</span><meta itemprop="copyrightHolder" content="Will Watts/Correspondent" /><span class="credit gallery-viewport-credit"> Will Watts/Correspondent</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide "  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo " data-mycapture-src="" data-mycapture-sm-src=""
                                
                                    data-src="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/1455c066-6b04-4934-a7fc-b1bd4bb24d8b-MP_2.jpg?width=520&amp;height=390&amp;fit=bounds&amp;auto=webp"
                                    data-large-src="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/1455c066-6b04-4934-a7fc-b1bd4bb24d8b-MP_2.jpg?width=1920&amp;height=1440&amp;fit=bounds&amp;auto=webp"
                                
                                alt="“The Best Risotto” from Marco Prime, Marco Island." data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="292" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption gallery-viewport-caption-no-mycapture"><span class="js-caption">“The Best Risotto” from Marco Prime, Marco Island.</span><meta itemprop="copyrightHolder" content="Will Watts/Correspondent" /><span class="credit gallery-viewport-credit"> Will Watts/Correspondent</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide "  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo " data-mycapture-src="" data-mycapture-sm-src=""
                                
                                    data-src="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/ff4ca915-0f13-4e48-9af9-020d5e9dcd8f-MP_3.jpg?width=520&amp;height=390&amp;fit=bounds&amp;auto=webp"
                                    data-large-src="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/ff4ca915-0f13-4e48-9af9-020d5e9dcd8f-MP_3.jpg?width=1920&amp;height=1440&amp;fit=bounds&amp;auto=webp"
                                
                                alt="Truffle and parmesan fries from Marco Prime, Marco Island." data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="292" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption gallery-viewport-caption-no-mycapture"><span class="js-caption">Truffle and parmesan fries from Marco Prime, Marco Island.</span><meta itemprop="copyrightHolder" content="Will Watts/Correspondent" /><span class="credit gallery-viewport-credit"> Will Watts/Correspondent</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide "  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo " data-mycapture-src="" data-mycapture-sm-src=""
                                
                                    data-src="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/58bf1918-0b1e-4305-b6cf-e75dbd860241-MP_4.jpg?width=520&amp;height=390&amp;fit=bounds&amp;auto=webp"
                                    data-large-src="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/58bf1918-0b1e-4305-b6cf-e75dbd860241-MP_4.jpg?width=1920&amp;height=1440&amp;fit=bounds&amp;auto=webp"
                                
                                alt="The roasted cauliflower from Marco Prime, Marco Island." data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="292" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption gallery-viewport-caption-no-mycapture"><span class="js-caption">The roasted cauliflower from Marco Prime, Marco Island.</span><meta itemprop="copyrightHolder" content="Will Watts/Correspondent" /><span class="credit gallery-viewport-credit"> Will Watts/Correspondent</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide "  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo " data-mycapture-src="" data-mycapture-sm-src=""
                                
                                    data-src="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/65b532f3-bb62-4d38-a9a7-507717edb07e-MP_9.jpg?width=520&amp;height=390&amp;fit=bounds&amp;auto=webp"
                                    data-large-src="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/65b532f3-bb62-4d38-a9a7-507717edb07e-MP_9.jpg?width=1920&amp;height=1440&amp;fit=bounds&amp;auto=webp"
                                
                                alt="The arugula salad from Marco Prime, Marco Island." data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="292" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption gallery-viewport-caption-no-mycapture"><span class="js-caption">The arugula salad from Marco Prime, Marco Island.</span><meta itemprop="copyrightHolder" content="Will Watts/Correspondent" /><span class="credit gallery-viewport-credit"> Will Watts/Correspondent</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide "  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo " data-mycapture-src="" data-mycapture-sm-src=""
                                
                                    data-src="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/355856fd-b63a-49ef-8037-c9470c9363aa-MP_8.jpg?width=520&amp;height=390&amp;fit=bounds&amp;auto=webp"
                                    data-large-src="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/355856fd-b63a-49ef-8037-c9470c9363aa-MP_8.jpg?width=1920&amp;height=1440&amp;fit=bounds&amp;auto=webp"
                                
                                alt="The â€˜Traditional Caesarâ€™ from Marco Prime, Marco Island." data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="292" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption gallery-viewport-caption-no-mycapture"><span class="js-caption">The â€˜Traditional Caesarâ€™ from Marco Prime, Marco Island.</span><meta itemprop="copyrightHolder" content="Will Watts/Correspondent" /><span class="credit gallery-viewport-credit"> Will Watts/Correspondent</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide "  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo " data-mycapture-src="" data-mycapture-sm-src=""
                                
                                    data-src="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/ea8788fd-0748-4a76-97e0-7fc9a7001f78-MP_5.jpg?width=520&amp;height=390&amp;fit=bounds&amp;auto=webp"
                                    data-large-src="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/ea8788fd-0748-4a76-97e0-7fc9a7001f78-MP_5.jpg?width=1920&amp;height=1440&amp;fit=bounds&amp;auto=webp"
                                
                                alt="Assorted bread from Marco Prime, Marco Island." data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="292" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption gallery-viewport-caption-no-mycapture"><span class="js-caption">Assorted bread from Marco Prime, Marco Island.</span><meta itemprop="copyrightHolder" content="Will Watts/Correspondent" /><span class="credit gallery-viewport-credit"> Will Watts/Correspondent</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide "  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo " data-mycapture-src="" data-mycapture-sm-src=""
                                
                                    data-src="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/1ee0e3b9-683b-4d4d-bcbe-7c78308198a8-MP_7.jpg?width=520&amp;height=390&amp;fit=bounds&amp;auto=webp"
                                    data-large-src="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/1ee0e3b9-683b-4d4d-bcbe-7c78308198a8-MP_7.jpg?width=1920&amp;height=1440&amp;fit=bounds&amp;auto=webp"
                                
                                alt="Key lime dessert from Marco Prime, Marco Island." data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="292" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption gallery-viewport-caption-no-mycapture"><span class="js-caption">Key lime dessert from Marco Prime, Marco Island.</span><meta itemprop="copyrightHolder" content="Will Watts/Correspondent" /><span class="credit gallery-viewport-credit"> Will Watts/Correspondent</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide "  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo " data-mycapture-src="" data-mycapture-sm-src=""
                                
                                    data-src="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/b773c862-d591-4695-a7ec-04ce04137309-MP_6.jpg?width=520&amp;height=390&amp;fit=bounds&amp;auto=webp"
                                    data-large-src="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/b773c862-d591-4695-a7ec-04ce04137309-MP_6.jpg?width=1920&amp;height=1440&amp;fit=bounds&amp;auto=webp"
                                
                                alt="Cheesecake from Marco Prime, Marco Island." data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="292" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption gallery-viewport-caption-no-mycapture"><span class="js-caption">Cheesecake from Marco Prime, Marco Island.</span><meta itemprop="copyrightHolder" content="Will Watts/Correspondent" /><span class="credit gallery-viewport-credit"> Will Watts/Correspondent</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide endslate"><div class="gallery-photo-border"><div class="gallery-endslate"><!-- HTML for the endslate content card --><h3 class="gallery-endslate-header">Interested in this topic? You may also want to view these photo galleries:</h3><ul class="gallery-endslate-related"  data-media-url="https://www.gannett-cdn.com/media/"></ul><div class="gallery-endslate-actions"><div class="gallery-actions-replay">Replay</div></div></div></div></div></div><div class="gallery-thumbs thumbs" data-name="compGalleryThumbs"><div class="thumbswrapper"><ul class="thumbslist scrollable-content"><li class="thumb-item active"><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/81669307-8eb4-4f03-aefb-652370d0029d-MP_1.jpg?crop=3193,2395,x3,y0&amp;width=80&amp;height=60&amp;fit=bounds" alt="The fennel tuna from Marco Prime, Marco Island." width="80" height="60"><span class="thumb-count">1 of 9</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/1455c066-6b04-4934-a7fc-b1bd4bb24d8b-MP_2.jpg?crop=3193,2395,x3,y0&amp;width=80&amp;height=60&amp;fit=bounds" alt="“The Best Risotto” from Marco Prime, Marco Island." width="80" height="60"><span class="thumb-count">2 of 9</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/ff4ca915-0f13-4e48-9af9-020d5e9dcd8f-MP_3.jpg?crop=3193,2395,x3,y0&amp;width=80&amp;height=60&amp;fit=bounds" alt="Truffle and parmesan fries from Marco Prime, Marco Island." width="80" height="60"><span class="thumb-count">3 of 9</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/58bf1918-0b1e-4305-b6cf-e75dbd860241-MP_4.jpg?crop=3192,2394,x0,y0&amp;width=80&amp;height=60&amp;fit=bounds" alt="The roasted cauliflower from Marco Prime, Marco Island." width="80" height="60"><span class="thumb-count">4 of 9</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/65b532f3-bb62-4d38-a9a7-507717edb07e-MP_9.jpg?crop=3192,2394,x0,y0&amp;width=80&amp;height=60&amp;fit=bounds" alt="The arugula salad from Marco Prime, Marco Island." width="80" height="60"><span class="thumb-count">5 of 9</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/355856fd-b63a-49ef-8037-c9470c9363aa-MP_8.jpg?crop=3192,2394,x0,y0&amp;width=80&amp;height=60&amp;fit=bounds" alt="The â€˜Traditional Caesarâ€™ from Marco Prime, Marco Island." width="80" height="60"><span class="thumb-count">6 of 9</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/ea8788fd-0748-4a76-97e0-7fc9a7001f78-MP_5.jpg?crop=3192,2394,x0,y0&amp;width=80&amp;height=60&amp;fit=bounds" alt="Assorted bread from Marco Prime, Marco Island." width="80" height="60"><span class="thumb-count">7 of 9</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/1ee0e3b9-683b-4d4d-bcbe-7c78308198a8-MP_7.jpg?crop=2589,1942,x0,y226&amp;width=80&amp;height=60&amp;fit=bounds" alt="Key lime dessert from Marco Prime, Marco Island." width="80" height="60"><span class="thumb-count">8 of 9</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/presto/2020/07/28/PMIF/b773c862-d591-4695-a7ec-04ce04137309-MP_6.jpg?crop=2539,1905,x0,y360&amp;width=80&amp;height=60&amp;fit=bounds" alt="Cheesecake from Marco Prime, Marco Island." width="80" height="60"><span class="thumb-count">9 of 9</span></div></a></li></ul></div></div><div class="feature-btns"><div class="ticker feature-btns-control"></div><div class="autoplay feature-btns-control"><span class="playbtn feature-btns-label">Autoplay</span></div><div class="thumbnails feature-btns-control"><span class="thumbLabel feature-btns-label">Show Thumbnails</span></div><div class="captions feature-btns-control"><span class="captionLabel feature-btns-label">Show Captions</span></div></div><a class="slide-nav prev gallery-prev" rel="prev">Last Slide</a><a class="slide-nav next gallery-next" rel="next">Next Slide</a></div><div class="gallery-leaderboard-ad"><div class="partner-placement leaderboard-companion-ad" data-ad-placement="leaderboard_atf" data-ad-sizes="[[728,90]]"></div></div></div></div><div id="module-position-S5x9hHvVsE4" class="story-asset story-metadata-asset"></div><div id="module-position-S5x9hHvL_xc" class="story-asset inline-share-tools-asset"><div class="inline-share-tools asset-inline-share-tools asset-inline-share-tools-top"><span
        class="inline-share-btn inline-share-btn-facebook"
        data-share-method="facebook"
        data-uotrack="InlineShareFacebookBtn"><span class="inline-share-count inline-share-count-facebook"></span><span class="inline-share-btn-label inline-share-btn-label-facebook">CONNECT</span></span><a
        class="inline-share-btn inline-share-btn-twitter"
        data-share-method="twitter"
        data-uotrack="InlineShareTwitterLink"
        data-popup-width="550"
        data-popup-height="450"
        href="https://twitter.com/intent/tweet?url=https%3A//www.marconews.com/story/entertainment/2020/07/31/watts-dinner-takeout-edition-treat-yourself-marco-prime/5528660002/&amp;text=%E2%80%98Watts%20for%20Dinner%E2%80%99%20the%20Takeout%20Edition%3A%C2%A0Treat%20yourself%20to%20Marco%20Prime&amp;via=marconews"
        target="_blank" data-popup
        rel="nofollow"><span class="inline-share-count inline-share-count-twitter"></span><span class="inline-share-btn-label inline-share-btn-label-twitter">TWEET</span></a><a
        class="inline-share-btn inline-share-btn-linkedin"
        data-share-method="linkedin"
        data-popup-width="600"
        data-popup-height="455"
        data-uotrack="UtilityBarFlyoutLinkedInLink"
        href="http://www.linkedin.com/shareArticle?url=https%3A//www.marconews.com/story/entertainment/2020/07/31/watts-dinner-takeout-edition-treat-yourself-marco-prime/5528660002/&amp;mini=true"
        target="_blank" data-popup
        rel="nofollow"><span class="inline-share-count inline-share-count-linkedin"></span><span class="inline-share-btn-label inline-share-btn-label-linkedin">LINKEDIN</span></a><span
            class="inline-share-btn inline-share-btn-comments"
            data-share-method="comments"
            data-uotrack="InlineShareCommentsBtn"><span class="inline-share-count inline-share-count-comments"></span><span class="inline-share-btn-label inline-share-btn-label-comments">COMMENT</span></span><span
        class="inline-share-btn inline-share-btn-email"
        data-share-method="email"
        data-uotrack="InlineShareEmailBtn"><span class="inline-share-count inline-share-count-email"></span><span class="inline-share-btn-label inline-share-btn-label-email">EMAIL</span></span><span
         class="inline-share-btn inline-share-btn-more"
         data-share-method="facebook"
         data-uotrack="InlineShareMoreBtn"><span class="inline-share-count inline-share-count-more"></span><span class="inline-share-btn-label inline-share-btn-label-more">MORE</span></span></div></div><p class="speakable-p-1 p-text">Our next dining destination is Marco Prime Steak &amp; Seafood in Marco Walk Plaza; and due to social distancing guidelines, we’re continuing to take our food to go; freeing up space for other diners.</p><p class="speakable-p-2 p-text">First, we were happy to see staff wearing masks. And when we visited, diners seemed to be spread out with no occupied tables neighboring each other.</p><p class="p-text">Things got off to an appetizing start with a couple of fresh salads. I had the traditional Caesar ($13) featuring chopped romaine, pecorino and parmigiana cheese, with house-made croutons and dressing. My partner in dine had the arugula salad ($14) featuring red onions, tomatoes, strawberries, candied pecans, goat cheese and a balsamic glaze. </p><p class="p-text"><span class="exclude-from-newsgate"><strong style="margin-right:3px;">More: </strong><a data-track-label="inline|intext|n/a" href="/story/entertainment/2020/07/24/watts-dinner-the-crazy-flamingo-marco-mainstay/5479728002/" target="_blank">‘Watts for Dinner’ the Takeout Edition: The Crazy Flamingo is a Marco mainstay</a></span></p><p class="p-text">Both salads were fresh and huge. The Caesar featured large slivers of cheese and a nice tangy dressing. The arugula was as colorful as a fall day with an amazing blend of sweet and savory.</p><div class="partner-placement partner-spike" data-ad-placement="native-article_link" data-ad-sizes='["fluid",[3,3], [2,6], [300,250]]'></div><p class="p-text">For my main dish, I picked the fennel tuna ($37) featuring a fennel and black-pepper dusted seared rare tuna filet in a bed of couscous, agrodolce (a traditional sweet and sour sauce in Italian cuisine) with vegetables. The sweet soy butter sauce and Rayu chili oil blended for a subtle yet lively flavor that complimented the meat very well.  </p><p class="p-text">For his entrée, my guest enjoyed “The Best Risotto” ($30) featuring wild mushrooms, burrata cheese, peas, corn, toasted pistachios and a sweet soy glaze. While the description may sound like a side dish, let me tell you it’s a solid and delicious main course.</p><div class="partner-placement partner-spike" data-ad-placement="native-article_link" data-ad-sizes='["fluid",[3,3], [2,6], [300,250]]'></div><p class="p-text">Both entrees came from the house specialties section of the main menu.</p><p class="p-text">For a side, I had the tempting and delectable truffle and parmesan fries ($10). It’s a big order, and might I suggest sharing with a friend; because it’s hard to stop eating them.</p><cta-atoms-container-inline></cta-atoms-container-inline><p class="p-text"><span class="exclude-from-newsgate"><strong style="margin-right:3px;">More: </strong><a data-track-label="inline|intext|n/a" href="/story/entertainment/2020/07/17/watts-dinner-takeout-edition-cocomos-get-there-fast-take-slow/5437967002/" target="_blank">‘Watts for Dinner’ the Takeout Edition: Cocomo's, get there fast; take it slow</a></span></p><p class="p-text">My dining companion had the roasted cauliflower ($10) seasoned with garlic and olive oil. Cooked to perfection – meaning still a bit crunchy and not mush – this dish is the perfect compliment for nearly any dish.  </p><p class="p-text">Our order also came with complimentary assorted and tasty breads.  </p><p class="p-text">We also order the cheesecake, always a solid performer, and a dessert inspired by key lime pie, only a little lighter and fluffier. Amazing!</p><p class="p-text">Although Marco Prime can be a little steep if you’re watching your money, it’s still a good choice for special occasions or just to treat yourself.  </p><p class="p-text"><span class="exclude-from-newsgate"><strong style="margin-right:3px;">More: </strong><a data-track-label="inline|intext|n/a" href="/story/entertainment/2020/07/31/hey-marco-island-looking-for-place-eat/5526211002/" target="_blank">Hey Marco Island, looking for a place to eat?</a></span></p><p class="p-text"><em>This newspaper pays for all meals related to dining reviews. We do not solicit or accept free food.</em></p><h2 class="presto-h2">If you go</h2><p class="p-text"><strong>Marco Prime Steak &amp; Seafood</strong></p><ul><li>599 S Collier Blvd., Marco Island</li><li>marcoprime.com</li><li>239-389-2333</li></ul><div id="module-position-S5x9hHuSyVY" class="story-asset inline-share-tools-asset"><div class="inline-share-tools asset-inline-share-tools asset-inline-share-tools-bottom"><span
        class="inline-share-btn inline-share-btn-facebook"
        data-share-method="facebook"
        data-uotrack="InlineShareFacebookBtn"><span class="inline-share-count inline-share-count-facebook"></span><span class="inline-share-btn-label inline-share-btn-label-facebook">CONNECT</span></span><a
        class="inline-share-btn inline-share-btn-twitter"
        data-share-method="twitter"
        data-uotrack="InlineShareTwitterLink"
        data-popup-width="550"
        data-popup-height="450"
        href="https://twitter.com/intent/tweet?url=https%3A//www.marconews.com/story/entertainment/2020/07/31/watts-dinner-takeout-edition-treat-yourself-marco-prime/5528660002/&amp;text=%E2%80%98Watts%20for%20Dinner%E2%80%99%20the%20Takeout%20Edition%3A%C2%A0Treat%20yourself%20to%20Marco%20Prime&amp;via=marconews"
        target="_blank" data-popup
        rel="nofollow"><span class="inline-share-count inline-share-count-twitter"></span><span class="inline-share-btn-label inline-share-btn-label-twitter">TWEET</span></a><a
        class="inline-share-btn inline-share-btn-linkedin"
        data-share-method="linkedin"
        data-popup-width="600"
        data-popup-height="455"
        data-uotrack="UtilityBarFlyoutLinkedInLink"
        href="http://www.linkedin.com/shareArticle?url=https%3A//www.marconews.com/story/entertainment/2020/07/31/watts-dinner-takeout-edition-treat-yourself-marco-prime/5528660002/&amp;mini=true"
        target="_blank" data-popup
        rel="nofollow"><span class="inline-share-count inline-share-count-linkedin"></span><span class="inline-share-btn-label inline-share-btn-label-linkedin">LINKEDIN</span></a><span
            class="inline-share-btn inline-share-btn-comments"
            data-share-method="comments"
            data-uotrack="InlineShareCommentsBtn"><span class="inline-share-count inline-share-count-comments"></span><span class="inline-share-btn-label inline-share-btn-label-comments">COMMENT</span></span><span
        class="inline-share-btn inline-share-btn-email"
        data-share-method="email"
        data-uotrack="InlineShareEmailBtn"><span class="inline-share-count inline-share-count-email"></span><span class="inline-share-btn-label inline-share-btn-label-email">EMAIL</span></span><span
         class="inline-share-btn inline-share-btn-more"
         data-share-method="facebook"
         data-uotrack="InlineShareMoreBtn"><span class="inline-share-count inline-share-count-more"></span><span class="inline-share-btn-label inline-share-btn-label-more">MORE</span></span></div></div><div class="article-print-url">Read or Share this story: https://www.marconews.com/story/entertainment/2020/07/31/watts-dinner-takeout-edition-treat-yourself-marco-prime/5528660002/</div><script>
window.simpleExclusion = window.simpleExclusion || [];
window.simpleTarget = window.simpleTarget || [];
Array.prototype.push.apply(window.simpleExclusion, ["custom-abbive"]);
Array.prototype.push.apply(window.simpleTarget, ["custom-abbive"]);
</script></div><aside class="story-right-rail"><section id="module-position-S5x9hHsLwgI" class="storyrightrail-bucket poster-ad-asset-module story-poster-ad-asset-module"><div class="partner-placement partner-asset-right-ad" data-ad-placement="poster" data-ad-sizes="[[300,250],[300,600],[300,1050]]"></div></section><section id="module-position-S5x9hHtqfDY" class="storyrightrail-bucket jobs-search-module story-jobs-search-module"><div class="jobs-search-wrapper right-rail"><a class="jobs-search-logo-link" href="https://jobs.marconews.com/Jobs/" data-track-label="thejobnetwork|thejobnetwork"><img class="jobs-search-logo" src="https://www.gannett-cdn.com/uxstatic/marconews/uscp-web-static-4525.70.0/images/jobs-logo.png" /></a><div id="jobs-search-form" class="jobs-search-form" data-url="http://jobs.marconews.com/Jobs/" data-affiliateId="None"><div class="jobs-search-field"><input type="text" name="keyword" id="jobs-search-keyword" class="jobs-search-text-input jobs-search-keyword" placeholder="Keywords (ex. registered nurse)" autocomplete="off"></div><div class="jsm-search-suggestions jsm-keyword-suggestions hidden"><span class="jsm-close-icon"></span><ul id="jsm-keywords" class="jsm-suggestions-list jsm-keywords"></ul></div><div class="jobs-search-field"><input type="text" name="location" id="jobs-search-location" class="jobs-search-text-input jobs-search-location" value="" placeholder="Location (ex. Chicago, IL or 50907)" autocomplete="off"></div><div class="jsm-search-suggestions jsm-location-suggestions hidden"><span class="jsm-close-icon"></span><ul id="jsm-locations" class="jsm-suggestions-list jsm-locations"></ul></div><div class="jobs-search-submit"><a class="jobs-search-btn"><span class="jobs-search-icon"></span><span class="jobs-search-btn-text">Find Jobs</span></a></div></div></div></section><section id="module-position-S5x9hHt9shU" class="storyrightrail-bucket feedback-opinionlabs-module story-feedback-opinionlabs-module"><div class="fbol-container"><div class="fbol-content"><a class="fbol-link" href="#" data-analytics="survey_click_story" data-cta="rightrail">Share your feedback</a>
         to help improve our site experience!
    </div></div></section><section id="module-position-S5x9hHtoGeQ" class="storyrightrail-bucket sponsor-button-ad-module story-sponsor-button-ad-module"><div class="partner-placement sponsor-button-ad" data-ad-placement="sponsor_button"  data-ad-sizes="[[300,50]]"></div></section><section id="module-position-S5x9hHsSAmU" class="storyrightrail-bucket taboola-poster-asset-module story-taboola-poster-asset-module"><div id="taboola-abp-right-rail-thumbnails"></div></section><section id="module-position-S5x9hHsyEMs" class="storyrightrail-bucket car-search-module story-car-search-module"></section><section id="module-position-S5x9hHsH6Ps" class="storyrightrail-bucket poster-ad-asset2-module story-poster-ad-asset2-module"><div class="partner-asset-right-ad-2"><div class="poster-scroll"><div class="partner-placement poster-scroll-ad" data-ad-placement="poster_scroll" data-ad-sizes="[[300,250],[300,600],[300,1050]]"></div></div></div></section></aside><section id="module-position-S5x9hHthxFo" class="storybottombar-bucket taboola-related-module story-taboola-related-module"><div class="more more-stories-wrap"><div class="more-stories-content"><div id="js-taboola-wrapper"><div id="taboola-grid-3x3"></div><div id="taboola-organic-grid-3x3"></div><div id="taboola-short-article-2x5"></div><div id="taboola-organic-short-article-2x5"></div><div id="taboola-grid-sports-3x3"></div><div id="taboola-organic-grid-sports-3x3"></div></div></div></div><div class="clearfix"></div></section><section id="module-position-S5x9hHsQyQU" class="storybottombar-bucket leaderboard-ad-module story-leaderboard-ad-module"><div class="partner-placement leaderboard-btf-ad leaderboard-ad" data-ad-placement="leaderboard_btf" data-ad-sizes="[[728,90]]"></div></section><section id="module-position-S5x9hHt7Mh4" class="storymessaging-bucket persistent-meter-module story-persistent-meter-module"><cta-atoms-container-persistent-fixed></cta-atoms-container-persistent-fixed></section><footer class="site-footer clearfix site-footer-dr-styling"><ul class="utility"><li class="util-li first"><a class="contactus" href="http://static.marconews.com/contactus/" data-ht="footercontact-us"><span class="big-icon"></span>Contact Us</a></li><li class="util-li last"><a class="rss" href="http://static.marconews.com/rss/" data-ht="footerrss-feeds" target="_blank"><span class="big-icon"></span>RSS Feeds</a></li></ul><div class="footer site-footer-fixed-width"><nav><div class="fronts"><section class="home"><h6><a href="/" data-ht="footerhome">Home</a></h6></section><section class="news"><h6><a href="/news/" data-ht="footernews">News</a></h6></section><section class="sports"><h6><a href="/news/sports/" data-ht="footersports">Sports</a></h6></section><section class="life"><h6><a href="/things-to-do/life/" data-ht="footerlife">Life</a></h6></section><section class="opinion"><h6><a href="/news/opinion/" data-ht="footeropinion">Opinion</a></h6></section><section class="entertainment"><h6><a href="/entertainment/" data-ht="footerentertainment">Entertainment</a></h6><ul class="site-footer-section-list site-footer-list"><li class="site-footer-section-item site-footer-list-item"><a class="site-footer-section-link site-footer-list-link" href="/things-to-do/outdoors/" data-ht="footeroutdoors">Outdoors</a></li></ul></section><section class="travel"><h6><a href="/travel/" data-ht="footertravel">Travel</a></h6></section><section class="obituaries"><h6><a href="http://www.legacy.com/obituaries/naplesnews/" data-ht="footerobituaries">Obituaries</a></h6></section><section class="naples-daily-news site-footer-section-more"><h6><a href="http://www.naplesnews.com" data-ht="footernaples-daily-news">Naples Daily News</a></h6></section><section class="usa-today site-footer-section-more"><h6><a href="https://www.usatoday.com" data-ht="footerusa-today">USA TODAY</a></h6></section><section class="weather site-footer-section-more"><h6><a href="/weather/" data-ht="footerweather">Weather</a></h6></section></div><section class="site-footer-meta site-footer-meta-fixed-width"><img src="https://www.gannett-cdn.com/sites/marconews/images/footer-logo@2x.png" class="site-footer-logo" alt="Marco News"><ul class="site-footer-social-icon-list site-footer-social-icon-list-fixed-width"><li class="site-footer-social-icon-item"><a class="soc-fb site-footer-social-icon-link site-footer-social-icon-link-soc-fb" href="https://www.facebook.com/themarcoeagle/" data-uotrack="footerfacebook" rel="nofollow"></a></li><li class="site-footer-social-icon-item"><a class="soc-tw site-footer-social-icon-link site-footer-social-icon-link-soc-tw" href="https://twitter.com/marconews" data-uotrack="footertwitter" rel="nofollow"></a></li></ul><p class="site-footer-meta-text site-footer-meta-text-fixed-width">&copy; 2020 www.marconews.com. All rights reserved.</p></section><section class="services site-footer-section-services site-footer-section-services-fixed-width"><h3>Services</h3><ul class="site-footer-list"><li class="site-footer-list-item"><a class="site-footer-list-link  "
                                   href="http://www.ndnadvertising.com/"
                                data-ht="footeradvertise-with-us"
                                >Advertise with Us</a></li><li class="site-footer-list-item"><a class="site-footer-list-link  "
                                   href="http://static.naplesnews.com/circulars/?1"
                                data-ht="footerweekly-ads"
                                target="_blank"
                                >Weekly Ads</a></li><li class="site-footer-list-item"><a class="site-footer-list-link  "
                                   href="https://cm.marcoislandflorida.com/terms"
                                data-ht="footerterms-of-service"
                                >Terms of Service</a></li><li class="site-footer-list-item"><a class="site-footer-list-link  "
                                   href="https://cm.marcoislandflorida.com/privacy-policy"
                                data-ht="footeryour-california-privacy-rightsprivacy-policy"
                                >Your California Privacy Rights/Privacy Policy</a></li><li class="site-footer-list-item"><a class="site-footer-list-link  "
                                   href=""
                                data-ht="footerad-choices"
                                >Ad Choices</a></li><li class="site-footer-list-item"><a class="site-footer-list-link  "
                                   href="https://cm.marconews.com/advertising-terms-conditions"
                                data-ht="footeradvertising-terms-and-conditions"
                                >Advertising Terms and Conditions</a></li><li class="site-footer-list-item"><a class="site-footer-list-link  "
                                   href="https://cm.marconews.com/ethical-conduct"
                                data-ht="footerour-ethical-principles"
                                >Our Ethical Principles</a></li><li class="site-footer-list-item"><a class="site-footer-list-link  "
                                   href="https://cm.marconews.com/accessibility"
                                data-ht="footeraccessibility-support"
                                >Accessibility Support</a></li><li class="site-footer-list-item"><a class="site-footer-list-link  "
                                   href="http://floridapublicnotices.com/"
                                data-ht="footerpublic-notices"
                                >Public Notices</a></li><li class="site-footer-list-item"><a class="site-footer-list-link  "
                                   href="/sitemap/"
                                data-ht="footersitemap"
                                >Sitemap</a></li></ul><ul class="site-footer-list"><li class="site-footer-list-item"><a class="site-footer-list-link ot-sdk-show-settings" href="#" data-ht="footerdo-not-sell-my-data-cookie-policy">Do not sell my data / Cookie policy</a></li><li class="site-footer-list-item"><a class="site-footer-list-link " href="https://cm.marcoislandflorida.com/privacy" data-ht="footerprivacy-policy">Privacy Policy</a></li></ul></section><section class="partners site-footer-section-partners site-footer-section-partners-fixed-width"><h3>Our Partners</h3><ul class="site-footer-list"><li class="site-footer-list-item"><a class="site-footer-list-link" href="http://www.naplesnews.com/marketplace/jobs/" data-ht="footerjobs" rel="nofollow " target="_blank">Jobs</a></li><li class="site-footer-list-item"><a class="site-footer-list-link" href="http://www.naplesnews.com/marketplace/cars/" data-ht="footercars" rel="nofollow " target="_blank">Cars</a></li><li class="site-footer-list-item"><a class="site-footer-list-link" href="http://naples.neighborhoodscope.com/" data-ht="footerhomes" rel="nofollow " target="_blank">Homes</a></li><li class="site-footer-list-item"><a class="site-footer-list-link" href="http://secure.adpay.com/SearchResultsDisplay.aspx?p=2051" data-ht="footerclassifieds" rel="nofollow " target="_blank">Classifieds</a></li><li class="site-footer-list-item"><a class="site-footer-list-link" href="https://www.thanksgiving.com" data-ht="footerthanksgivingcom" rel="nofollow ">Thanksgiving.com</a></li><li class="site-footer-list-item"><a class="site-footer-list-link" href="https://grateful.co" data-ht="footergrateful" rel="nofollow ">Grateful</a></li></ul></section></nav></div></footer><!-- comscorekw=entertainment --><script type="json/pageinfo" class="pageinfo">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</script></article></div><div class="arrows overlay-arrows"><script type="text/template" id="overlay-arrow-wrap"><% if (disabled) { %><a class="overlay-content-arrows overlay-arrows-<%= dir %>-wrap <%= disabled %>" data-ht="articlearrow<%= dir %>"></a><% }else{ %><a class="overlay-content-arrows overlay-content-arrows-<%= dir %>-wrap <%= disabled %>" href="<%= links %>" data-ht="articlearrow<%= dir %>"><div class="overlay-arrow-<%= dir %> overlay-arrows-anchor"><div class="overlay-arrows-<%= dir %>-anchor-image"></div></div></a><% } %></script></div></div><div id="overlay-film" class="ui-film show"></div><div id="ad-staging"></div><div class="partner-popup"></div><!--[if lt IE 9]><script type="text/javascript" src="https://www.gannett-cdn.com/uxstatic/marconews/uscp-web-static-4525.70.0/jsb/main_legacy.min.js"></script><![endif]--><!--[if gt IE 8]><!--><script type="text/javascript" src="https://www.gannett-cdn.com/uxstatic/marconews/uscp-web-static-4525.70.0/jsb/main.min.js"></script><!--<![endif]--><script src="https://login.gcion.com/GANNETT-GUP/resources/kit/js/norequirejs.common.min.js" id="jskit"></script><script type="text/javascript">
        
        require(["gdp-usf/kit/js/user_factory_def", "gdp-usf/kit/js/feature_personalized_link_def", "gdp-usf/kit/js/client_helpers"],
            function(UserFactory, PersonalizedLinkFactory, ClientHelpers) {
                window.UserFactory = UserFactory;
                window.PersonalizedLinkFactory = PersonalizedLinkFactory;
                window.ClientHelpers = ClientHelpers;
            }
        );
        </script><div id="fb-root"></div><script src="https://www.gannett-cdn.com/appservices/gidgits-js/gidgits.min.js" id="gidgits-script"></script><script type="text/javascript">
        var mainAd = document.createElement('div');
        mainAd.id = 'main_ad';
        mainAd.style.cssText = 'height:1px; width:1px; overflow:auto;position: absolute;left: -999em;';
        document.body.appendChild(mainAd);
        var blockPosition = document.getElementById('main_ad');
        if(blockPosition && blockPosition.offsetHeight == 1) {
            window.adsEnabled = true;
        }
    </script><script>
/* Wrapper for Gannett, generated on 2018-11-08T16:48:57-05:00 */
(function() {
    var e, s;
    var config = (window.site_vars && window.site_vars.ADS && window.site_vars.ADS.confiant) ? window.site_vars.ADS.confiant : {};
    var cb = function(blockingType, blockingId, isBlocked, wrapperId, tagId, impressionData) {

        // Log block event to NewRelic
        if (window.newrelic) {
            window.newrelic.addPageAction('advertisingConfiant', {
                blockingType: blockingType,
                blockingId: blockingId,
                isBlocked: isBlocked,
                wrapperId: wrapperId,
                tagId: tagId
            });
        }

        // Refresh blocked ads
        if (config.refreshBlocked) {
            var slotId = impressionData && impressionData.dfp && impressionData.dfp.s;
            if (slotId && window.adManager && window.adManager.activeSlotStatistics && window.adManager.activeSlotStatistics.slots) {
                window.googletag = window.googletag || {};
                window.googletag.cmd = window.googletag.cmd || [];
                window.googletag.cmd.push(function () {
                    window.adManager.activeSlotStatistics.slots.forEach(function (slot) {
                        if (slot.id === slotId && slot.adSlot) {
                            slot.adSlot.refresh();
                        }
                    })
                });
            }
        }
    };

    if (config.enabled || window.location.search.indexOf('confiant_debug') !== -1) {
        window.confiant = window.confiant || {};
        window.confiant.enable_integrations = ['gpt'];
        window.confiant.callback = cb;

        e = document.createElement('script');
        e.async = true;
        e.src = config && config.scriptUrl || 'https://confiant-integrations.global.ssl.fastly.net/r5TdgVvkbv-PeaJCKaQfCh5Xsto/gpt_and_prebid/config.js';
        s = document.getElementsByTagName('script')[0];
        s.parentNode.insertBefore(e, s);

    }
})();
</script></body></html>
